PyPy 团队宣布发布 PyPy2.7 v5.8(支持 Python 2.7 语法的解释器)和一个 beta 版本的 PyPy3.5 v5.8(支持 Python 3.5 语法的解释器)。这两个版本都是基于相同的代码库。请注意,PyPy3.5 仅支持 Linux 64 位。

PyPy2.7 版本包含 upstream stdlib 2.7.13 版本,PyPy3.5 包含 upstream stdlib 3.5.3 版本。

还有以下亮点:

  • 修复了 Shadowstack RootFinder 垃圾收集器策略中多线程程序崩溃的关键错误
  • 向 vmprof 统计分析器中的配置文件框添加了原生 PyPy 支持
  • pack * 和 unpack * 结构模块功能速度加快,Microbenchmarks 上显示有 2-10 倍的加速
  • 添加了(默认情况下禁用)链接时间优化和基本解释器的配置文件引导优化,这可能使未受影响的代码运行速度更快。要使用这些,请使用适当的选项进行设置。

点此查看完整更新内容

下载地址:

http://pypy.org/download.html

PyPy 是一个强兼容的 Python 解释器,几乎可以替代 CPython 2.7 和 CPython 3.5。 由于其集成的跟踪 JIT 编译器,速度非常快(PyPy 和 CPython 2.7.x 性能比较)。

9 收藏


直接登录

推荐关注