jQuery 3.0 预览版发布,此版本是 jQuery 3.0 的第一个 Alpha 预览版!此版本主要特性:支持现代化浏览器和 IE9 环境。同时还发布了 jQuery Compat 3.0 Alpha 版本,此版本主要特性:支持 IE8!

jQuery 3.0 Alpha 和 jQuery Compat 3.0 Alpha 都支持 Yandex,一个 2012 年发布的浏览器,可以从 jQuery CDN 或者这里直接下载:

https://code.jquery.com/jquery-3.0.0-alpha1.js
https://code.jquery.com/jquery-compat-3.0.0-alpha1.js

使用 npm 安装:

npm install jquery@3.0.0-alpha1

npm install jquery-compat@3.0.0-alpha1

此版本可以使用 jQuery 迁移插件进行升级。

值得关注的特性

  • 简化 .show() 和 .hide() 方法
  • 修改 .data() 名称,更新 .data() 实现,能更好的匹配 HTML5 数据集规范
  • jQuery.Deferred 现在兼容 Promises/A+ 和 ES2015
  • 样式表设为 display:none 的元素,show() 无法让该元素显示
  • 移除 jQuery.ajax 的特定 Deferred 方法
  • 尝试性增加错误提醒
  • .width(), .height(), .css(“width”) 和 .css(“height”) 可以返回小数值
  • 移除废弃的事件别名(.load, .unload 和 .error)
  • 不能在 jQuery 对象中访问 jQuery.swap, jQuery.buildFragment 和 jQuery.domManip
  • Animations 现在使用 requestAnimationFrame
  • .unwrap( selector )
  • 大幅度提升 jQuery 自定义选择器速度

中文摘要来自OSChina

6 收藏


直接登录

推荐关注